Results tagged ‘ Release Notes ’

New Build Yesterday: A209

Hi all,
I apologize for the late update on the new build for you all. Yesterday mid-day, we released A209, which contains the following updates:

-Line score related bug fixes
-Always on top mode update for PC version
-Archive video bug fixes (scrub issues on PC at end of game & displaying archive available too early)
-Postponed game updates
-Updates for MLB.com media services/login services

Thank you again for all of the time you’re putting in. By the numbers, it appears that the app is extremely engaging for those that are using it. Please continue to either email in to the mosaic team or post issues here, and we’ll be addressing them as they come up.

In addition, we’re working on getting the support forum up to aggregate recommendations and solutions to issues so that you don’t all have to go searching through the blog.

Thanks,

Justin

New Build Available: A208

Hi all,
We’ve been off the air for a bit from a build perspective, but released a new one for you this morning. It includes updates in the following area:

– Swarmcast updates/bugfixes for better high quality streaming
– Addition of Swarmcast version for troubleshooting
– Video updates to mosaic client/install to detect incompatible hardware
– Mac stability/bugfixes
– CPU usage is now better on the Mac
– Additional on-demand playback updates

Again, we appreciate all of your feedback. The engineering team and I are continuing to work with you all via the threads here to provide support, and we’re also in parallel now working on getting a support forum set up to consolidate what we all have learned and shared with you.

Thanks,

Justin

New Build Available A205

Hi all,
We have a new build available for you that I’ve just posted. The changes in this build are a new version of swarmcast, designed to help those of you that have been having difficulties with the medium and high quality streams on the 4/6 game panel views. It should not affect anything else. For reference, this is build A205, as seen in the preferences panel within the mosaic. Also – apparently we have a fan at the chicago tribune, of both the mosaic and the blog. You can check out the review here.

UPDATE: Aside from the new build, prior to our evening games starting tonight, we’re doing some maintenance work on the 4/6 game streams right now – so if you see intermittent availability for the next hour, this is why – its not related to the new build.

Thanks again,

Justin

New Build, and other updates

Hi all,
It’s great to see such active commentary on the blog, we all appreciate your time and are working hard to get those of you still struggling working. For a fast response, the best way to get to us is to post here, or email mosaic@website.mlb.com. I’m also going through emails and getting back to you as quickly as i’m able, but so you’re aware – we have the whole team of engineers reading the mosaic@website.mlb.com emails and responding as we’re able. Thank you all again for the time you’ve put into the product. Its been great to hear from those of you that are pleased with it as well as those that are not. The feedback is invaluable as we continue to enhance Mosaic going forward. In the meantime, for those of you still having trouble, you can always check out the high quality feeds via the multimedia guide in the browser at: Multimedia Guide

On to the release. This release should fix the following:

– Audio/Video Syncing bug related to some on-demand game playback
– New release of Swarmcast
– Crashes on game select/audio select with an error of HRESULT E_FAIL that some of you have seen on the PC version.
– Archive games should now start at the correct place, so you don’t have to watch the pre-game show
– On-demand condensed games/highlights/top plays should now be working for everyone
– Mac version dropping out of full screen on rebuffer
– Mac version updates to game archive status

In addition, we’re continuing to refine our install process. To that end, we’ve added an easy to find version number in the preferences window. If you click on the box next to preferences in the top right corner of the mosaic window, you’ll see the preferences window pop up. in the lower left corner of that window, you should now see that the version number is A204. If you don’t have A204, or don’t see it there – it means you’re probably running an early version that is having trouble self-updating. If that is the case, we’d appreciate you taking the time to re-download and re-install. We’re sorry for the inconvenience, and are confident that barring local system issues we’ve cleaned up the self-update process with the newer versions of the Mosaic application.

As always, thanks again for engaging in the conversation on the blog. Some of you will notice today that the blackouts resemble our normal weekly schedule – so i hope you have a nice afternoon watching baseball.

Thanks,

Justin

New Build Available

Hi all,
There is a new build available that addresses application fixes and additional stability issues we’ve seen. We’ve also introduced functionality that will allow for us to show you all something we’ve been working on that I think you’ll enjoy. Stay tuned – update on this coming first thing in the morning after we’ve had a successful night of testing.

Thanks,

Justin

BTW: I’ve got a big pile of email from you, and appreciate you taking the time to write in. You’re not going unheard, just had a busy day focused on the app. I’ll be getting back to those of you who wrote in regarding mosaic issues by tomorrow morning. Thank you for your patience.

Easter Build

Hi all,
We just put a build up that should fix those of you having the problem on the PC where audio would start playing but you would just see black screens in the mosaic for 15-30 seconds before video comes in (sometimes worse).

Thanks,

Justin

New Build Available

Hi all,
We have another new build for you all, addressing the following:

-Mac Audio fixes – we’re hoping this has cleared the issues from yesterday up, as well as the slowdown on audio switch issue.
-Multiple quality levels for on-demand playback
-Speeding up login on the PC
-Mosaic daily refresh process hanging some of you up is cleaned up
-Box score fixes
-Game status fixes
-Debugging/troubleshooting error messages added for sound card/driver related issues

I have a long list of emails from many of you to reply to, which I’m working through now. Apologize if i’ve been a bit slow to get back to some of you – but if you email about a mosaic related issue, i will get back to you. Again though, your best bet for a quick reply is via commenting here. We’re working on a few other ideas to consolidate feedback and issues, that will be a bit easier to track than the blog.

Thanks again for your comments and feedback. We’re all committed to getting this working for all of you. Anecdotally, traffic on the mosaic is looking quite good, and it appears that more and more of you are getting used to the app and spending more time on it, which is good to see.

Justin

New Build Available

UPDATE: If you’re on a mac and on the new build, and having newfound audio trouble, we’re terribly sorry for the inconvenience and will have it resolved by tomorrow morning at the latest. In the meantime, a workaround is to change the volume level, then change it back to where you want it, and you should be fine.
Hi all,

We just released a new build, which should address the following:

– Additional Blackout/Credit Card Verification screen related fixes
– Fixed a number of Vista related issues
– PC and Mac Audio not playing on startup – this should be resolved
– Audio Freezing on Mac when changing focus
– Mac clock stops running
– Vista Install
– Clickable Linescores

Going Forward, we’re continuing to focus on the following (as well as triaging install issues on a one-on-one basis):

– Blackout issues
– Video Quality Enhancements
– PC Version video startup on high quality streams stays black before video comes in for ~10 seconds
– Video scrubbing
– Continued audio/video playback issues
– Other bug fixes across the app

For those of you still having trouble, if the self-updater doesn’t seem to be working, i’ll ask that you uninstall and reinstall. I know that this is a pain, but in reviewing our logs it appears that a number of you are still running quite old versions of the client and as we’re fixing bugs causing the problems you’re noting, you should be using the latest build. We’re continuing to refine our self-update process to make this as seamless as possible, and promise that you won’t have to reinstall often. If things are running well for you without a reinstall, then go right ahead and continue.

Again, the whole team here thanks you all for taking the time to come and provide feedback and comment. We have a team of engineers going through the threads here and responding, and while I apologize i’ve been off the air here a bit more than usual in the past 24 hours, please trust that I’m not going to rest until we’ve identified all of your problems, and either resolved them, or given you suggestions about upgrading your machine and network connection. The whole team has been working days and nights, and will continue through the weekend to make sure we’re addressing issues as efficiently and quickly as we can.

To that end, I’ve also been getting a lot of mail from you all, which i appreciate, and I’m doing my best to respond to as quickly as possible. However, if you could limit your questions to Mosaic specific issues, and when i see repeated questions, I’ll blog about answers to them, it will help me actually prioritize and keep the team working on fixing bugs in the software.

Thanks again,

Justin Shaffer

Vista Issues Today

Hi all,
We’ve just posted up a new release that we believe should fix the majority of the Vista issues introduced today. The self-updater should work (just close and re-open the mosaic, and it will self-update), and you should be able to get back in if you were able to before.

We have reports of this running well on vista pro and vista home, but need admin access on vista home premium. We’ll be continuing to work through these issues to make for more consistent behaviour over the next few days.

If you’re still having trouble after this update, please try the following:

1. For both the install and when running the app afterwards, right click on the icon and select Run As Administrator
2. If you’re still having trouble after the self-update, please try and uninstall and then re-install, as administrator.

Please also note that both the Mosaic and the Swarmcast app that gets installed need access to the internet, so when the Windows Firewall pops up and asks, you should let them have access.

Again, many thanks for all of the feedback. Please let us know if this latest release helps those of you that were able to get in before.

Thanks,

Justin

New Release for Windows Users

UPDATE: We’re aware of the issue with install on Vista introduced by the new release, and are working to resolve it. Check back here for updates. Thanks!
Hi all,

We just posted a new release that should fix the startup audio issue on the PCs (audio not on when you first start the app or when you switch streams). In addition, we doing some things differently with video on the PC version now, which should significantly improve playback quality on the streams. Some of you had accurately commented earlier that it didnt look the same as it does in the media player on the site, and it now should.

Again, thanks for all of your comments. We have a dedicated team of engineers going through the threads here and responding (in addition to me) to issues that are raised here. I’ve also spoken with a ton of you all today, and am doing my best to get back to emails as well.

I’ll be putting up in a bit a summary of where we think we are and provide an opportunity for you guys to give us some feedback on new features and functionality we introduced this year.

Thanks again,

Justin